By The Integrity360 Team on December 29, 2020

Check Point Upgrade Advisory

Breaches, Alerts & Advisories

Update needed for Check Point Client VPN/Endpoint versions E81.10 or earlier

Integrity360 would like to draw your attention to an important update issued by Check Point to all customers using Client VPN/Endpoint versions E81.10 or earlier.

Check Point issued an update as they identified several customers were still using the older versions:

  • Endpoint/VPN E80.81 to E81.10 (Windows only)
  • SandBlast agent E80.61 to E81.10 (Windows only) 

As per their communication, if you are affected, please ensure you upgrade to a newer version (recommended) or apply a simple fix to the old version as the above versions will cease to operate on January 1st 2021.

Information is provided in the update from Check Point, however, should you require support please contact your account manager or call +353 1 293 4027/+44 20 3397 3414.  

Useful Resources

https://www.checkpoint.com/solutions/update-client-vpn-endpoint-versions/